Jump to content

Full and Concise Installation Instructions Needed

Recommended Posts




I host a few client sites around the World, most are e-commerce but some (yuk!) Wordpress.

I manage both VPS and dedicated servers, using Proxmox on a couple dedicated ones and various control panels (cPanel/CWP/Directadmin/HestiaCP) on Cloudlinux, CentOS 7 and debian 9/10.

Though I'm not a security specialist, my servers thankfully haven't been hacked (yet!), primarily by following good hosting practices.

In short, I've been doing this stuff for quite a while. ;)



What a nightmare I've had trying to get this software to install/run! 😮 I've re-installed multiple times, on all the control panels mentioned above. On one instance (DA), the admin was horrendously slow, taking minutes to update each screen. Once, on a CWP install (after many attempts) I got things apparently running quite well but there were loads of errors appearing in logs.


I've tried beginning from the master.zip download as well as ClicShopping_V3-version3.2145.zip - of which there are quite a few discrepancies; the lack of a shop directory being the main one.

The supplied .htaccess files make a horrible default setting, which is often unacceptable in a secured environment.

Options -Indexes
Options +FollowSymlinks
Options -MultiViews

Any web server that is publicly accessible should be setup with as secure an environment as possible. Some commercially available shared hosting providers are poorly configured, so don't take those as a good baseline - why do you think so many websites get hacked?!

Typically, Apache is configured to use suexec/suphp/PHP-FPM or a combination of these. It's a means to restrict what each user account can access on the server and prevents mistakes such as permissions of 777 on directories and 666 on files. These World writable permissions should NEVER be used and if you find they must be, in order to do something web-based then your server is configured wrong. Simple. In some stricter setups the maximum permissions are 750/640 but 755/644 is more commonly used/acceptable.



I've tried installing with PHP 7.3 & 7.4 (7.4 is mentioned in the install instructions) and in all cases there have been some glitches. The stumbling block is in step 4 of the installation where the logo and top links appear and the rest of the page causes a 'hidden' 500 error. No error appears in either the domlog or Apache general log - very strange!

Using Firefox debugging tools, I see that jquery and fontawesome codes are retrieved but resource://gre is blank. ExtensionContent.jsm seems to be the culprit, wherever that is intended to be fetched from.


Link to post



Nice you have lot experience.  It will be nice if you can propose a tutorial about the security, Some people do not have some knowledge with htaccess as a newbiz as me.

About your nightmare, not for me, the installation is simple after to secure correctly  a software on a server it's another stuff. I hate htaccess.


  • Thanks 1
Link to post

I dare say if I setup a basic webserver with little/no security then it'll install fine. I might find time to do that on a temporary not-for-production VPS. TBH, I'm getting a bit 'scunnered', having been doing this stuff for a few days now.

I've got clients that would benefit from migrating their current stores to ClicShopping, if I can get a stable environment. In doing so, then it gives me impetus to give back to the community, even if only for feedback, suggestions and critique.


Link to post

Went with debian 9/ISPConfig/PHP 7.4.11 FPM this time,with the "version3.2145.zip'.

Same/similar result,with step 4 halting, though this time resource://gre loaded.

Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:82.0) Gecko/20100101 Firefox/82.0

Note: I didn't enter any SMTP details,if that's makes any difference.



Link to post



I am sorry to hear you to not able to install ClicShopping.

Until now, I install the application lot of time on different server and every time everything works fine on the best hoster known, fast-cgi or FPM.

To be sure, I retested the master and everything works fine.

I never had a problem with that and some very big partner (very known) use this application without problem or propose this application to install automatically.

If you dot change the permission about configuration file in 777, yes you can have this problem, but after you must put these file in 444. That' all.


I can do  a quickly test for you if you give all information, ftp and mysql. That's all I can do for you.


Thank you.


  • Like 2
  • Thanks 1
Link to post

After MUCH messing around, tweaking permissions and manually importing the "ISAM" SQL file, as well as removing/re-adding the default clic_ prefix, I appear to have something up and running again. :-/

I've done a manual backup, plus let the automated backup run, before doing anything further. This may become my template for future installs - let's see.

Thanks for at least trying @ClicShopping - I do hope my stress levels calm down a bit today. I'm too old for these unnecessary complications. :'(

Link to post

@Julie  It's far from ideal and I'm taking numerous backups whilst 'tweaking' but at least I'm getting places. 😉


When/if I find time, I can hopefully streamline the installation process, assuming this software allows me to get the basics up & running. Now back to trying a migration.. (another thread.)


Edited by AlwaysSkint
Link to post

I'm back!

Part of my installation issues were due to trying to install within CentosWebPanel (CWP) and CentOS 7. By default, mariadb 10.1 is installed. I didn't notice the requirement that ClicShopping works near the bleeding edge - for e-commerce long-term stability is a thing. ;) It does explain how I managed to get further with DirectAdmin/CentOS 7, as that combination includes a mariadb 10.4 option by default.

I installed/licensed Softaculous on the CWP server, which highlighted the version problem during the installation. This should really be a part of the standard setup routine, in my opinion. that would've saved me a lot of time/grief!

I now have CWP upgraded to mariadb 10.3..


First failure: the ClicShoppingAdmin default .htaccess has invalid definitions, causing 500 errors - thankfully easily fixed.

#Options -Indexes
#Options +FollowSymlinks
#Options -MultiViews

The next set of errors is much more problematic On a fresh installation from Softaculous, with no demo data:

[06-Nov-2020 12:14:34 America/New_York] PHP Notice:  Undefined index: MessageStack_Data in /home/clic/public_html/shop/includes/ClicShopping/OM/MessageStack.php on line 35
[06-Nov-2020 12:14:34 America/New_York] PHP Notice:  Trying to access array offset on value of type bool in /home/clic/public_html/shop/includes/ClicShopping/Apps/Orders/Orders/Classes/Shop/Order.php on line 591
[06-Nov-2020 12:14:34 America/New_York] PHP Notice:  Trying to access array offset on value of type bool in /home/clic/public_html/shop/includes/ClicShopping/Apps/Orders/Orders/Classes/Shop/Order.php on line 592
[06-Nov-2020 12:14:34 America/New_York] PHP Notice:  Trying to access array offset on value of type bool in /home/clic/public_html/shop/includes/ClicShopping/Apps/Orders/Orders/Classes/Shop/Order.php on line 601
[06-Nov-2020 12:14:34 America/New_York] PHP Notice:  Trying to access array offset on value of type bool in /home/clic/public_html/shop/includes/ClicShopping/Apps/Orders/Orders/Classes/Shop/Order.php on line 602
[06-Nov-2020 12:14:35 America/New_York] PHP Notice:  Undefined property: ClicShopping\Sites\Shop\Search::$checkManufacturer in /home/clic/public_html/shop/includes/ClicShopping/Sites/Shop/Search.php on line 408

I better try upgrading to 10.4 and see if that helps - Softaculous installer said 10.2, if I recall.

Link to post

Just checked my debain 9/ispconfig test VPS: lo & behold..


mysql  Ver 15.1 Distrib 10.1.47-MariaDB, for debian-linux-gnu (x86_64) using readline 5.2

That explains why that one didn't go well either. 😕

I definitely think that you should emphasise that many installations will require a (manual) upgrade of mariadb, if not mysql.

Edited by AlwaysSkint
Link to post



I understand you will have a infrastructure problem. Your experience will help some other !

About maria Db 10.4, I am not installed and I am 10.3.x currently  (recommended for installation).

The test are been on ubuntu and debian, use mariadb 10.3.x  by default if I remeber well.


I make some mistake like that and  I do not understand why  a software can not work. If the infrastructure is too old not work, if you use something too new, also.


About the index Undefined index: ... , it would be resolved on the next release. A big go work has been made on that to respect the strict mode of php. In this case it's better to include reduce that.


Normally it's inside the code (includes/application_top.php) I think or change in php.ini


If your experience can help to create a better documentation,it's good for everybody.


  • Thanks 1
Link to post

Congratulations on the latest release!



With the latest release, I'll just rebuild one of my test stores. :)

It would be useful if there were notes on the best way to upgrade an existing store. Personally, I know how to do it manually with Meld and importing SQL but might be more useful for others.

(I wish I'd spotted the need to change the SQL statement from Anglais to English in the languages table. ;) )

Edited by AlwaysSkint
Link to post
INSERT INTO `clic_languages` VALUES(1, 'Anglais', 'en', 'gb', 'english', 1, 1, 'en_US.UTF-8;en_US.UTF8;enu_usa');

INSERT INTO `clic_languages` VALUES(1, 'English (GB)', 'en', 'gb', 'english', 1, 1, 'en_GB.UTF-8;en_GB.UTF8;enu_gb');
INSERT INTO `clic_languages` VALUES(3, 'English (US)', 'en', 'us', 'english', 1, 1, 'en_US.UTF-8;en_US.UTF8;enu_usa');


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...

Important Information

By using this site, you agree to our Terms of Use